Sonntag, 24. April 2011

Sync-Test of Kodak ZX1-Rig: Negative Results so far

Yesterday evening I made a few measurements of the resulting sync of the videos. The following test-sequence was made using 720p and 30 pics/sec:
  • Switch on cameras synchronously via USB remote
  • Start video recording on both cameras
  • Fire a flashlight (thanks Matthias for this great tip!)
  • Stop video recording on both cameras
  • Shutdown cameras
This sequence was repeated about 10 times and the resulting video-pairs were uploaded into the StereoMovieMaker. The video-pairs were then adjusted for frame-accuracy (this was still necessary because the start of the recording was done using the buttons on each camera) and the first frame that shows the flash was observed in detail.

Due to the rolling shutter, the flash manifests itself as a white area that starts at a specific line in the frame. In theory, with perfectly synchronized cameras, the lines where the flash starts would be identical in this frame and the resulting sync-error would be less than 46 microseconds (again, thanks Matthias for the explanation!).

What I observe for the ZX1-Pair is, unfortunately, a completely different behaviour: The lines where the flash starts differ quite randomly between about 100 lines and half a frame. This means that the cameras are in fact still completely unsynchronized.

A possible explanation for this behaviour could be that camera performs some additional steps during startup before the actual video-oszillator circuit starts and these additional steps are dependent on each camera and somehow random. For Sony Cameras and a LANC-remote the start of the cameras using LANC immediately starts the oszillator and the cameras (usually) start in perfect sync and then slowly drift apart later.

Maybe somebody has additional suggestions what went wrong here, but based on these results the USB-remote is completely useless and it would be sufficient to switch on each camera separately.

It would be very interesting to repeat this test with camcorders of other brands: If a camcorder starts automatically when connected via USB to a PC and you happen to own two of these cameras and a simple USB-hub then try the following:
  • Connect both camera via USB to the USB-hub
  • Connect the hub to a PC until the cameras boot
  • Start video recording on both cameras
  • Fire a flashlight
  • Stop video recording
  • Check the sync of the resulting video pair in StereoMovieMaker
If we find a cheap HD camera that delivers synched videos in this test, we have the perfect low-cost 3d action cam ;-)


Kommentare:

Adam Thomas hat gesagt…

Digital Recording Equipment. Very Nice Blog posting i like this post so much....

autothreads hat gesagt…

My 3D video rig uses Kodak Zx3 cameras. I've found that the remote control that you can buy for this series of Kodak cameras will start both cameras simultaneously. Using hand claps or light flashes as a reference, and Stereo Movie Maker to match the frames, the IR remote is an acceptable kludge. Fairly often they're on the same frame but even when they are not, they're off by just a handful of frames, much closer than when I manually start the two cameras recording, so that saves time in editing even when the sync isn't perfect to begin with.